System Requirements

Seequre – System Requirements

These are the minimum recommended system requirements for Seequre Server to run.
This does not take into account running multiple programs simultaneously.
If you are running a heavy I/O intensive server the impact on your server should be minimum, but we recomend that that server should be better then these recommendations.

The current version of Seequre Server is  2.0.1.0
Seequre Video Conferencing  Server – Minimum System Requirements

  • Microsoft Windows Server 2019, 2016, 2012, 2008r2
  • CPU 1200 MHz processor or higher (dual core CPU 2.4 GHz or higher recommended)
  • 4GB RAM (8 GB RAM recommended)
  • Typical Hard disk space required:  300 MB of free space for installation
  • Additional space needed for any chat or video conversations stored on the server
  • TCP/IP network protocol installed
  • Internet or Intranet communication capabilities
  • SQL Server (Microsft Sql Express or  Microsoft Sql)
  • MDaemon version 17 or newer on the same server for user API

Seequre is not heavily I/O intensive, but we are using it on some servers that are and have not noticed any difference or have seen any indication on the resource monitor that our integrated product is impacting it.

Required IIS components

The IIS components listed below satisfy the minimum requirements to run the Web Adaptor. If other IIS components are enabled, they do not need to be removed.

A SSL Certificate is needed for WebRTC and communication with other servers. (our installer will use letsencrypt to try to make one)

  • Web Server
    • Common HTTP Features
      • Default Document
      • Static Content
    • Security
      • Request Filtering
    • Application Development
      • .NET Extensibility 4.7
      • .NET Extensibility
      • ASP.NET 4.7
      • ASP.NET
      • ISAPI Extensions
      • ISAPI Filters
  • Management Tools
    • IIS Management Console
  • Windows server Features
    • Net Framework 3.5
    • Net Framework 4.7
    • ASP.NET 4.7
    • NET Core version 3.1

After version 2.0.2 of Seequre we require .NET Core version 3.1

https://docs.microsoft.com/en-us/dotnet/core/install/dependencies?tabs=netcore31&pivots=os-windows

Windows Client 7 SP1+, 8.1 x64, x86
Windows 10 Client Version 1607+ x64, x86
Windows Server 2012 R2+ x64, x86

Additional dependencies are required if you’re installing the .NET SDK or runtime on the following Windows versions:

  • Windows 7 SP1
  • Windows Vista SP 2
  • Windows 8.1
  • Windows Server 2008 R2
  • Windows Server 2012 R2

https://docs.microsoft.com/en-us/dotnet/core/install/dependencies?tabs=netcore31&pivots=os-windows